Elevated Worldpay US Declines
Incident Report for Invoiced
Resolved
This incident has been resolved.
Posted 6 months ago. Jun 25, 2018 - 23:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 months ago. Jun 25, 2018 - 22:56 UTC
Identified
We have identified the cause and are working on a fix.
Posted 6 months ago. Jun 25, 2018 - 22:39 UTC
Investigating
We're experiencing an elevated level of declines with the Worldpay US gateway and are currently looking into the issue.
Posted 6 months ago. Jun 25, 2018 - 17:30 UTC
This incident affected: Payments.