Some users unable to load admin dashboard
Incident Report for Invoiced
Resolved
The issue has been resolved.
Posted Jan 22, 2020 - 16:03 UTC
Monitoring
A fix has been released and we are currently monitoring the results. We recommend anyone currently affected by this issue presses the refresh button in their web browser.
Posted Jan 22, 2020 - 15:45 UTC
Identified
The issue has been identified and a fix is being implemented. Web browsers configured with certain locales can cause the dashboard to stop loading.
Posted Jan 22, 2020 - 15:42 UTC
Investigating
We are currently identifying this issue.
Posted Jan 22, 2020 - 15:42 UTC
This incident affected: Dashboard.